Language
Mobile SDK Guide
  1. Prerequisites
    1. Xcode
    2. CocoaPods CLI

Prerequisites

Before you can get started, you first need the key to open the door to our APIs! You can get your API Key and use the OneAtlas Mobile SDK by:


  1. Signing into your OneAtlas account

    Don’t yet have a OneAtlas account? Contact us via our main OneAtlas page.

  2. Selecting at least OneAtlas Data service.

  3. Using our API Key Generator.

Make sure to keep your API key safe, you will need this in the next step.

Xcode

Your development machine should have the latest version of Xcode installed.

CocoaPods CLI

The recommended way of installing our SDK is through CocoaPods, a widely used dependency management system for iOS and macOS development.

To install the CocoaPods CLI on your development machine, run this command in the Terminal:

$ sudo gem install cocoapods